CVE-2022-34265 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in django. 7 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for django — see the affected versions and patch details below.
Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
django🐍djangoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. The Trunc() and Extract() database functions are subject to SQL injection if untrusted data is used as a kind/lookup_name value. Applications that constrain the lookup name and kind choice to a known safe list are unaffected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | django | ≥ 3.2a1&&< 3.2.14 | 3.2.14pip install --upgrade 'django==3.2.14' |
| 🐍PyPI | django | ≥ 4.0a1&&< 4.0.6 | 4.0.6pip install --upgrade 'django==4.0.6' |
Affected Products
djangodjangoprojectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update django to 3.2.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-34265 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Applications that constrain the lookup name and kind choice to a known safe list are unaffected. Red Hat Satellite 6 versions include affected versions of python-django, however, the product is not vulnerable since it does not make use of vulnerable functions. Future updates may fix this issue.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.12 for RHEL 8 | python-django-0:3.2.14-2.el8pc | RHSA-2022:8506 |
| RHUI 4 for RHEL 8 | python-django-0:3.2.14-3.el8ui | RHSA-2022:5738 |
Frequently Asked Questions
Is CVE-2022-34265 in your dependencies?
Find it across PyPI, including transitive dependencies.