NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-34259 — community-edition

MEDIUMFix: magento/magento2@246d524

CVE-2022-34259 is a medium-severity (CVSS 5.3) CWE-284 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Adobe Commerce Improper Access Control Security feature bypass

Also known asBIT-magento-2022-34259GHSA-9wjf-94h3-r4rh
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-34259.

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.72%1.44%2.16%0.2%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to impact the availability of a user's minor feature. Exploitation of this issue does not require user interaction.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.3.0&&< 2.3.7-p42.3.7-p4composer require magento/community-edition:^2.3.7-p4
🐘Packagistmagento/community-edition≥ 2.4.4&&< 2.4.52.4.5composer require magento/community-edition:^2.4.5
🐘Packagistmagento/community-edition≥ 2.4.0&&< 2.4.3-p32.4.3-p3composer require magento/community-edition:^2.4.3-p3

Affected Products

2 products · 20 configurations
Application
commerceadobe
≥ 2.4.0 && < 2.4.3
3 versions
2.3.72.4.32.4.4
Application
magentomagento
≥ 2.4.0 && < 2.4.3
3 versions
2.3.72.4.32.4.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.3.7-p4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-34259 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to impact the availability of a user's minor feature. Exploitation of this issue does not require user interaction.
O3 Security · Impact-Aware SCA

Is CVE-2022-34259 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-34259: community-edition — Fixed in 2.3.7-p4