NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-34112 — dataease-plugin-common

MEDIUMFix: dataease/dataease@5f611d3

CVE-2022-34112 is a medium-severity (CVSS 6.5) CWE-732 vulnerability in io.dataease:dataease-plugin-common. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for io.dataease:dataease-plugin-common — see the affected versions and patch details below.

Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin

Also known asGHSA-c2pj-rr68-pw94
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.74%1.11%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.dataease:dataease-plugin-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator. Version 1.11.2 contains a patch for this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.dataease:dataease-plugin-commonall versions1.11.2io.dataease:dataease-plugin-common:1.11.2

Affected Products

1 product · 1 configurations
Application
dataeasedataease
1 version
1.11.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.dataease:dataease-plugin-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.dataease:dataease-plugin-common to 1.11.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-34112 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator. Version 1.11.2 contains a patch for this issue.
O3 Security · Impact-Aware SCA

Is CVE-2022-34112 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-34112: dataease-plugin — Fixed in 1.11.2