NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

CVE-2022-3363 — rdiffweb

LOWFix: ikus060/rdiffweb@c27c46b

CVE-2022-3363 is a low-severity (CVSS 2.8) CWE-840 vulnerability in rdiffweb. A fix is available for rdiffweb — see the affected versions and patch details below.

Business Logic Errors in ikus060/rdiffweb

Also known asGHSA-jw36-mrvg-j5fxPYSEC-2022-42978
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3363.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.00%0.50%1.00%1.51%0.5%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍rdiffweb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Business Logic Errors in GitHub repository ikus060/rdiffweb prior to 2.5.0a7.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIrdiffweball versions2.5.0a7pip install --upgrade 'rdiffweb==2.5.0a7'

Affected Products

1 product · 7 configurations
Application
rdiffwebikus-soft
< 2.5.0
1 version
2.5.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rdiffweb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rdiffweb to 2.5.0a7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3363 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Business Logic Errors in GitHub repository ikus060/rdiffweb prior to 2.5.0a7.
O3 Security · Impact-Aware SCA

Is CVE-2022-3363 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-3363: rdiffweb — Fixed in 2.5.0a7