NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-3362 — rdiffweb

MEDIUMFix: ikus060/rdiffweb@6efb995

CVE-2022-3362 is a medium-severity (CVSS 6.1) CWE-613 vulnerability in rdiffweb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for rdiffweb — see the affected versions and patch details below.

Insufficient Session Expiration in ikus060/rdiffweb

Also known asGHSA-94qm-99qc-qwqjPYSEC-2022-43000
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3362.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.97%1.46%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍rdiffweb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Insufficient Session Expiration in GitHub repository ikus060/rdiffweb prior to 2.5.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIrdiffweball versions2.5.0pip install --upgrade 'rdiffweb==2.5.0'

Affected Products

1 product · 1 configurations
Application
rdiffwebikus-soft
< 2.5.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rdiffweb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rdiffweb to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3362 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Insufficient Session Expiration in GitHub repository ikus060/rdiffweb prior to 2.5.0.
O3 Security · Impact-Aware SCA

Is CVE-2022-3362 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-3362: rdiffweb — Fixed in 2.5.0