CVE-2022-33157 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in subhh/libconnect. A fix is available for subhh/libconnect — see the affected versions and patch details below.
libconnect Extension for Typo3 Vulnerable to XSS
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
subhh/libconnect🐘subhh/libconnectReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | subhh/libconnect | all versions | 7.0.8composer require subhh/libconnect:^7.0.8 |
| 🐘Packagist | subhh/libconnect | ≥ 8.0.0&&< 8.1.0 | 8.1.0composer require subhh/libconnect:^8.1.0 |
Affected Products
libconnectlibconnect_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for subhh/libconnect, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update subhh/libconnect to 7.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-33157 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-33157 in your dependencies?
Find it across Packagist, including transitive dependencies.