NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2022-32172 — zincsearch

MEDIUMFix: zinclabs/zinc@3376c24

CVE-2022-32172 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in github.com/zincsearch/zincsearch. A fix is available for github.com/zincsearch/zincsearch — see the affected versions and patch details below.

Zinc - Cross-Site Scripting

Also known asGHSA-7j6x-42mm-p7jmGO-2023-1896
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.77%1.16%0.4%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/zincsearch/zincsearch🐹github.com/zinclabs/zinc

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

In Zinc, versions v0.1.9 through v0.3.1 are vulnerable to Stored Cross-Site Scripting when using the delete template functionality. When an authenticated user deletes a template with a XSS payload in the name field, the Javascript payload will be executed and allow an attacker to access the user’s credentials.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/zincsearch/zincsearch≥ 0.1.9&&< 0.3.20.3.2go get github.com/zincsearch/zincsearch@v0.3.2
🐹Gogithub.com/zinclabs/zinc≥ 0.1.9&&< 0.3.20.3.2go get github.com/zinclabs/zinc@v0.3.2

Affected Products

1 product · 1 configurations
Application
zinczinclabs
≥ 0.1.9 && ≤ 0.3.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/zincsearch/zincsearch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/zincsearch/zincsearch to 0.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-32172 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Zinc, versions v0.1.9 through v0.3.1 are vulnerable to Stored Cross-Site Scripting when using the delete template functionality. When an authenticated user deletes a template with a XSS payload in the name field, the Javascript payload will be executed and allow an attacker to access the user’s credentials.
O3 Security · Impact-Aware SCA

Is CVE-2022-32172 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-32172: zincsearch XSS — Fixed in 0.3.2