NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2022-32167 — cloudreve

MEDIUMFix: cloudreve/Cloudreve@4b85541

CVE-2022-32167 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in github.com/HFO4/cloudreve. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/HFO4/cloudreve — see the affected versions and patch details below.

Cloudreve - Stored XSS

Also known asGHSA-fg25-gq9g-32mx
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-32167.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.35%0.70%1.06%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/HFO4/cloudreve🐹github.com/cloudreve/Cloudreve/v3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/HFO4/cloudreve≥ 1.0.0No fix
🐹Gogithub.com/cloudreve/Cloudreve/v3≥ 3.0.0&&< 3.6.0-beta13.6.0-beta1go get github.com/cloudreve/Cloudreve/v3@v3.6.0-beta1

Affected Products

1 product · 1 configurations
Application
cloudrevecloudreve
≥ 1.0.0 && ≤ 3.5.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/HFO4/cloudreve, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2022-32167; check the affected-versions list above or the advisory for the patched release of github.com/HFO4/cloudreve, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.
O3 Security · Impact-Aware SCA

Is CVE-2022-32167 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-32167: cloudreve XSS — Fixed in 3.6.0-beta1