CVE-2022-32065 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.ruoyi:ruoyi. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for com.ruoyi:ruoyi — see the affected versions and patch details below.
RuoYi 4.7.3 vulnerable to arbitrary file upload in background management module
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.ruoyi:ruoyiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
An arbitrary file upload vulnerability in the background management module of RuoYi v4.7.3 and below allows attackers to execute arbitrary code via a crafted HTML file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.ruoyi:ruoyi | all versions | 4.7.4com.ruoyi:ruoyi:4.7.4 |
Affected Products
ruoyiruoyiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.ruoyi:ruoyi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.ruoyi:ruoyi to 4.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-32065 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-32065 in your dependencies?
Find it across Maven, including transitive dependencies.