NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-31190 — dspace-xmlui

MEDIUMFix: DSpace/DSpace@574e254

CVE-2022-31190 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in org.dspace:dspace-xmlui. A fix is available for org.dspace:dspace-xmlui — see the affected versions and patch details below.

Metadata of withdrawn Items is exposed to anonymous users in DSpace XMLUI

Also known asGHSA-7w85-pp86-p4pq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31190.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.95%1.42%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.dspace:dspace-xmlui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Metadata on a withdrawn Item is exposed via the XMLUI "mets.xml" object, as long as you know the handle/URL of the withdrawn Item. This vulnerability only impacts the XMLUI.

However, this vulnerability is very low severity as Item metadata does not tend to contain highly secure or sensitive information.

This vulnerability does NOT impact the JSPUI or 7.x.

Patches

Because of the low severity of this security issue, it requires updating to 6.4 to resolve. No patch is available for 5.x or below.

DSpace 6.x:

Apply the patch to your DSpace

If at all possible, we recommend upgrading your DSpace site based on the upgrade instructions. However, if you are unable to do so, you can manually apply the above patches as follows:

  1. Download the appropriate patch file to the machine where DSpace is running
  2. From the [dspace-src] folder, apply the patch, e.g. git apply [name-of-file].patch
  3. Now, update your DSpace site (based loosely on the Upgrade instructions). This generally involves three steps:
    1. Rebuild DSpace, e.g. mvn -U clean package (This will recompile all DSpace code)
    2. Redeploy DSpace, e.g. ant update (This will copy all updated WARs / configs to your installation directory). Depending on your setup you also may need to copy the updated WARs over to your Tomcat webapps folder.
    3. Restart Tomcat

Workaround

If there are any withdrawn items which are known to have highly secure information in their metadata, they can be permanently deleted. This will ensure their secure metadata is inaccessible & removed from the system entirely.

References

Discovered & reported by David Cavrenne of Atmire

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.dspace:dspace-xmlui≥ 4.0&&< 6.46.4org.dspace:dspace-xmlui:6.4

Affected Products

1 product · 1 configurations
Application
dspaceduraspace
≥ 4.0 && < 6.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.dspace:dspace-xmlui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.dspace:dspace-xmlui to 6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31190 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact Metadata on a withdrawn Item is exposed via the XMLUI "mets.xml" object, as long as you know the handle/URL of the withdrawn Item. This vulnerability only impacts the XMLUI. However, this vulnerability is very low severity as Item metadata does not tend to contain highly secure or sensitive information. _This vulnerability does NOT impact the JSPUI or 7.x._ ### Patches Because of the low severity of this security issue, it requires updating to 6.4 to resolve. _No patch is available for 5.x or below._ _DSpace 6.x:_ * Fixed in 6.4 via #2451 * 6.x patch file: https://github.com/
O3 Security · Impact-Aware SCA

Is CVE-2022-31190 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-31190: dspace-xmlui — Fixed in 6.4