NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
MEDIUM severity

CVE-2022-31100 — rulex

MEDIUMFix: rulex-rs/rulex@fac6d58

CVE-2022-31100 is a medium-severity (CVSS 6.5) Reachable Assertion vulnerability in rulex. A fix is available for rulex — see the affected versions and patch details below.

Reachable Assertion in rulex

Also known asGHSA-8v9w-p43c-r885RUSTSEC-2022-0031
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31100.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.38%0.4%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀rulex

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Impact

When parsing untrusted rulex expressions, rulex may crash, possibly enabling a Denial of Service attack. This happens when the expression contains a multi-byte UTF-8 code point in a string literal or after a backslash, because rulex tries to slice into the code point and panics as a result.

This is a security concern for you, if

  • your service parses untrusted rulex expressions (expressions provided by an untrusted user), and
  • your service becomes unavailable when the thread running rulex panics.

Patches

The crashes are fixed in version 0.4.3. Affected users are advised to update to this version.

Workarounds

You can use catch_unwind to recover from panics.

For more information

If you have any questions or comments about this advisory:

Credits

Credit for finding these bugs goes to

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iorulexall versions0.4.3cargo update -p rulex --precise 0.4.3

Affected Products

1 product · 1 configurations
Application
pomskypomsky-lang
< 0.4.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rulex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rulex to 0.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31100 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact When parsing untrusted rulex expressions, rulex may crash, possibly enabling a Denial of Service attack. This happens when the expression contains a multi-byte UTF-8 code point in a string literal or after a backslash, because rulex tries to slice into the code point and panics as a result. This is a security concern for you, if - your service parses untrusted rulex expressions (expressions provided by an untrusted user), and - your service becomes unavailable when the thread running rulex panics. ### Patches The crashes are fixed in version **0.4.3**. Affected users are advised t
O3 Security · Impact-Aware SCA

Is CVE-2022-31100 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2022-31100: rulex DoS — Fixed in 0.4.3