CVE-2022-31097 — grafana
HIGHCVE-2022-31097 is a high-severity (CVSS 7.3) Cross-site Scripting (XSS) vulnerability in github.com/grafana/grafana. EPSS puts its 30-day exploitation probability at 70.1% (99th percentile). A fix is available for github.com/grafana/grafana — see the affected versions and patch details below.
Stored XSS in Grafana's Unified Alerting
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31097.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/grafana/grafana🐹github.com/grafana/grafana🐹github.com/grafana/grafana🐹github.com/grafana/grafanaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Today we are releasing Grafana 8.3.10, 8.4.10, 8.5.9 and 9.0.3. This patch release includes a HIGH severity security fix for a stored Cross Site Scripting in Grafana.
Release v.9.0.3, containing this security fix and other patches:
Release v.8.5.9, containing this security fix and other fixes:
Release v.8.4.10, containing this security fix and other fixes:
Release v.8.3.10, containing this security fix and other fixes:
Stored XSS (CVE-2022-31097)
Summary
On June 19 a security researcher contacted Grafana Labs to disclose a XSS vulnerability in the Unified Alerting feature of Grafana. After analysis, this stored XSS could be used to elevate privileges from Editor to Admin.
We believe that this vulnerability is rated at CVSS 7.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N).
Impact
An attacker can exploit this vulnerability to escalate privilege from editor to admin by tricking an authenticated admin to click on a link.
Affected versions with HIGH severity
All Grafana >=8.0 versions are affected by this vulnerability.
Solutions and mitigations
All installations after Grafana v8.0 should be upgraded as soon as possible.
As a workaround it is possible to disable alerting or use legacy alerting.
Appropriate patches have been applied to Grafana Cloud and as always, we closely coordinated with all cloud providers licensed to offer Grafana Pro. They have received early notification under embargo and confirmed that their offerings are secure at the time of this announcement. This is applicable to Amazon Managed Grafana.
Timeline
Here is a detailed timeline starting from when we originally learned of the issue. All times in UTC.
2022-06-19 10:32 - Research submission of vulnerability report 2022-06-20 14:35- Issue triaged, confirmed positive, and internal incident raised 2022-06-20 18:40 - Fix PR submitted and reviewed 2022-06-23 07:12 - All Grafana Cloud hosted Grafana instances patched 2022-07-05 07:14 - Customers informed under embargo 2022-07-14 02:00 - Public release
Acknowledgement
We would like to thank Maxim Misharin for responsibly disclosing the vulnerability.
Reporting security issues
If you think you have found a security vulnerability, please send a report to [email protected]. This address can be used for all of Grafana Labs' open source and commercial products (including, but not limited to Grafana, Grafana Cloud, Grafana Enterprise, and grafana.com). We can accept only vulnerability reports at this address. We would prefer that you encrypt your message to us by using our PGP key. The key fingerprint is
F988 7BEA 027A 049F AE8E 5CAA D125 8932 BE24 C5CA
The key is available from keyserver.ubuntu.com.
Security announcements
We maintain a security category on our blog, where we will always post a summary, remediation, and mitigation details for any patch containing security fixes.
You can also subscribe to our RSS feed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/grafana/grafana | ≥ 9.0.0&&< 9.0.3 | 9.0.3go get github.com/grafana/grafana@v9.0.3 |
| 🐹Go | github.com/grafana/grafana | ≥ 8.5.0&&< 8.5.9 | 8.5.9go get github.com/grafana/grafana@v8.5.9 |
| 🐹Go | github.com/grafana/grafana | ≥ 8.4.0&&< 8.4.10 | 8.4.10go get github.com/grafana/grafana@v8.4.10 |
| 🐹Go | github.com/grafana/grafana | ≥ 8.0.0&&< 8.3.10 | 8.3.10go get github.com/grafana/grafana@v8.3.10 |
Affected Products
grafanagrafanae-series performance analyzernetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/grafana/grafana, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/grafana/grafana to 9.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31097 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Disable Unified alerting. https://grafana.com/docs/grafana/latest/setup-grafana/configure-grafana/#unified_alertingSource: Red Hat security advisory for CVE-2022-31097 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ceph Storage 6.1 | rhceph/rhceph-6-dashboard-rhel9:6-75 | RHSA-2023:3642 |
Frequently Asked Questions
Is CVE-2022-31097 in your dependencies?
Find it across Go, including transitive dependencies.