CVE-2022-31053 — biscuit-auth
CRITICALCVE-2022-31053 is a critical-severity (CVSS 9.8) CWE-347 vulnerability in biscuit-auth. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for biscuit-auth — see the affected versions and patch details below.
Signature forgery in Biscuit
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31053.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
biscuit-auth🐹github.com/biscuit-auth/biscuit-go☕com.clever-cloud:biscuit-javaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io, Go, Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The paper Cryptanalysis of Aggregate Γ-Signature and Practical Countermeasures in Application to Bitcoin defines a way to forge valid Γ-signatures, an algorithm that is used in the Biscuit specification version 1. It would allow an attacker to create a token with any access level.
As Biscuit v1 was still an early version and not broadly deployed, we were able to contact all known users of Biscuit v1 and help them migrate to Biscuit v2. We are not aware of any active exploitation of this vulnerability.
Patches
The version 2 of the specification mandates a different algorithm than gamma signatures and as such is not affected by this vulnerability. The Biscuit implementations in Rust, Haskell, Go, Java and Javascript all have published versions following the v2 specification.
Workarounds
There is no known workaround, any use of Biscuit v1 should be migrated to v2.
References
Cryptanalysis of Aggregate Γ-Signature and Practical Countermeasures in Application to Bitcoin
For more information
If you have any questions or comments about this advisory:
- Open an issue in biscuit-auth/biscuit
- Ask questions on Matrix
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | biscuit-auth | ≥ 1.0.0&&< 2.0.0 | 2.0.0cargo update -p biscuit-auth --precise 2.0.0 |
| 🐹Go | github.com/biscuit-auth/biscuit-go | all versions | 2.0.0go get github.com/biscuit-auth/biscuit-go@v2.0.0 |
| ☕Maven | com.clever-cloud:biscuit-java | all versions | 2.0.0com.clever-cloud:biscuit-java:2.0.0 |
Affected Products
biscuit-authbiscuitsecbiscuit-gobiscuitsecbiscuit-haskellbiscuitsecbiscuit-javaclever-cloudResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for biscuit-auth, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update biscuit-auth to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31053 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-31053 in your dependencies?
Find it across crates.io, Go, Maven, including transitive dependencies.