NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-31049 — cms-core

MEDIUMFix: TYPO3/typo3@da61177

CVE-2022-31049 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

Cross-Site Scripting in Frontend Login Mailer

Also known asBIT-typo3-2022-31049GHSA-h4mx-xv96-2jgm
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31049.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.13%0.51%0.89%1.27%0.6%0.8%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms🐘typo3/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Meta

  • CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C (4.9)

Problem

User submitted content was used without being properly encoded in HTML emails sent to users. The actually affected components were mail clients used to view those messages.

Solution

Update to TYPO3 versions 9.5.35 ELTS, 10.4.29, 11.5.11 that fix the problem described above.

Credits

Thanks to Christian Seifert who reported this issue and to TYPO3 framework merger Andreas Fernandez who fixed the issue.

References

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 9.0.0&&< 9.5.359.5.35composer require typo3/cms-core:^9.5.35
🐘Packagisttypo3/cms-core≥ 10.0.0&&< 10.4.2910.4.29composer require typo3/cms-core:^10.4.29
🐘Packagisttypo3/cms-core≥ 11.0.0&&< 11.5.1111.5.11composer require typo3/cms-core:^11.5.11
🐘Packagisttypo3/cms≥ 10.0.0&&< 10.4.2910.4.29composer require typo3/cms:^10.4.29
🐘Packagisttypo3/cms≥ 11.0.0&&< 11.5.1111.5.11composer require typo3/cms:^11.5.11

Affected Products

1 product · 3 configurations
Application
typo3typo3
≥ 11.0.0 && < 11.5.11
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 9.5.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31049 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

> ### Meta > * CVSS: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C` (4.9) ### Problem User submitted content was used without being properly encoded in HTML emails sent to users. The actually affected components were mail clients used to view those messages. ### Solution Update to TYPO3 versions 9.5.35 ELTS, 10.4.29, 11.5.11 that fix the problem described above. ### Credits Thanks to Christian Seifert who reported this issue and to TYPO3 framework merger Andreas Fernandez who fixed the issue. ### References * [TYPO3-CORE-SA-2022-004](https://typo3.org/security/advisory/typo3-
O3 Security · Impact-Aware SCA

Is CVE-2022-31049 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-31049: cms-core — Fixed in 9.5.35