NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-31020 — indy-node

HIGHFix: hyperledger/indy-node@fe50747

CVE-2022-31020 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in indy-node. A fix is available for indy-node — see the affected versions and patch details below.

Remote code execution in Indy's NODE_UPGRADE transaction

Also known asGHSA-r6v9-p59m-gj2pPYSEC-2022-265
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31020.

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
1.08%1.66%2.23%2.81%1.6%2.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍indy-node

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The pool-upgrade request handler in Indy-Node <=1.12.4 allows an improperly authenticated attacker to remotely execute code on nodes within the network.

Network operators are strongly encouraged to upgrade to the latest Indy-Node release >=1.12.5 as soon as possible.

Patches

The pool-upgrade request handler in Indy-Node >=1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution.

Mitigations

Network operators are strongly encouraged to upgrade to the latest Indy-Node release >=1.12.5 as soon as possible.

Acknowledgements

Thank you to @shakreiner at CyberArk Labs for finding and responsibly disclosing this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIindy-nodeall versions1.12.5rc1pip install --upgrade 'indy-node==1.12.5rc1'

Affected Products

1 product · 1 configurations
Application
indy-nodelinuxfoundation
≤ 1.12.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for indy-node, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update indy-node to 1.12.5rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31020 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact The `pool-upgrade` request handler in Indy-Node `<=1.12.4` allows an improperly authenticated attacker to remotely execute code on nodes within the network. Network operators are strongly encouraged to upgrade to the latest Indy-Node release `>=1.12.5` as soon as possible. ### Patches The `pool-upgrade` request handler in Indy-Node `>=1.12.5` has been updated to properly authenticate `pool-upgrade` transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. ### Mitigations Network operators a
O3 Security · Impact-Aware SCA

Is CVE-2022-31020 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-31020: indy-node RCE — Fixed in 1.12.5rc1