NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-30874 — nukeviet

MEDIUMFix: nukeviet/nukeviet@1f328bb

CVE-2022-30874 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in nukeviet/nukeviet. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nukeviet/nukeviet — see the affected versions and patch details below.

Cross-site Scripting in NukeViet CMS

Also known asGHSA-pm37-5j5m-6cvw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.44%0.89%1.33%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nukeviet/nukeviet

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

There is a Cross Site Scripting Stored (XSS) vulnerability in NukeViet CMS before 4.5.02.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnukeviet/nukevietall versions4.5.02composer require nukeviet/nukeviet:^4.5.02

Affected Products

1 product · 1 configurations
Application
nukevietnukeviet
< 4.5.02
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nukeviet/nukeviet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nukeviet/nukeviet to 4.5.02 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-30874 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

There is a Cross Site Scripting Stored (XSS) vulnerability in NukeViet CMS before 4.5.02.
O3 Security · Impact-Aware SCA

Is CVE-2022-30874 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-30874: nukeviet XSS — Fixed in 4.5.02