CVE-2022-30600 is a critical-severity (CVSS 9.8) CWE-682 vulnerability in moodle/moodle. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moodle/moodle — see the affected versions and patch details below.
Incorrect Calculation in moodle
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in moodle where logic used to count failed login attempts could result in the account lockout threshold being bypassed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 4.0&&< 4.0.1 | 4.0.1composer require moodle/moodle:^4.0.1 |
| 🐘Packagist | moodle/moodle | ≥ 3.9&&< 3.9.14 | 3.9.14composer require moodle/moodle:^3.9.14 |
| 🐘Packagist | moodle/moodle | ≥ 3.10&&< 3.10.11 | 3.10.11composer require moodle/moodle:^3.10.11 |
| 🐘Packagist | moodle/moodle | ≥ 3.11&&< 3.11.7 | 3.11.7composer require moodle/moodle:^3.11.7 |
Affected Products
fedorafedoraprojectmoodlemoodleenterprise linuxredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 4.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-30600 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-30600 in your dependencies?
Find it across Packagist, including transitive dependencies.