NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-30597 — moodle

MEDIUMFix: moodle/moodle@6702689

CVE-2022-30597 is a medium-severity (CVSS 5.3) CWE-472 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

External Control of Assumed-Immutable Web Parameter in moodle

Also known asBIT-moodle-2022-30597GHSA-x6gm-qqwp-76gr
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.23%1.84%0.5%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in moodle where the description user field was not hidden when being set as a hidden user field.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.0&&< 4.0.14.0.1composer require moodle/moodle:^4.0.1
🐘Packagistmoodle/moodle≥ 3.11&&< 3.11.73.11.7composer require moodle/moodle:^3.11.7
🐘Packagistmoodle/moodle≥ 3.10&&< 3.10.113.10.11composer require moodle/moodle:^3.10.11
🐘Packagistmoodle/moodle≥ 3.9&&< 3.9.143.9.14composer require moodle/moodle:^3.9.14

Affected Products

3 products · 8 configurations
OS
fedorafedoraproject
3 versions
343536
Application
moodlemoodle
≥ 3.11 && < 3.11.7
1 version
4.0.0
OS
enterprise linuxredhat
1 version
8.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-30597 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A flaw was found in moodle where the description user field was not hidden when being set as a hidden user field.
O3 Security · Impact-Aware SCA

Is CVE-2022-30597 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-30597: moodle — Fixed in 4.0.1