CVE-2022-29773 — aleksis-core
MEDIUMCVE-2022-29773 is a medium-severity (CVSS 6.5) vulnerability in aleksis-core. A fix is available for aleksis-core — see the affected versions and patch details below.
Access control issue in AlekSIS-Core
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
aleksis-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An access control issue in aleksis/core/util/auth_helpers.py: ClientProtectedResourceMixin of AlekSIS-Core v2.8.1 and below allows attackers to access arbitrary scopes if no allowed scopes are specifically set.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aleksis-core | all versions | 2.9pip install --upgrade 'aleksis-core==2.9' |
Affected Products
aleksisaleksisDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aleksis-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aleksis-core to 2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29773 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-29773 in your dependencies?
Find it across PyPI, including transitive dependencies.