CVE-2022-29631 is a high-severity (CVSS 7.5) CWE-74 vulnerability in org.jodd:jodd-http. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jodd:jodd-http — see the affected versions and patch details below.
Server-Side Request Forgery in Jodd HTTP
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jodd:jodd-httpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jodd HTTP v6.0.9 was discovered to contain multiple CLRF injection vulnerabilities via the components jodd.http.HttpRequest#set and `jodd.http.HttpRequest#send. These vulnerabilities allow attackers to execute Server-Side Request Forgery (SSRF) via a crafted TCP payload.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jodd:jodd-http | ≥ 5.0.0&&< 6.2.1 | 6.2.1org.jodd:jodd-http:6.2.1 |
Affected Products
jodd httpjoddResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jodd:jodd-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jodd:jodd-http to 6.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29631 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2022-29631 in your dependencies?
Find it across Maven, including transitive dependencies.