NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-29599 — maven-shared-utils

CRITICALFix: apache/maven-shared-utils#40

CVE-2022-29599 is a critical-severity (CVSS 9.8) CWE-116 vulnerability in org.apache.maven.shared:maven-shared-utils. A fix is available for org.apache.maven.shared:maven-shared-utils — see the affected versions and patch details below.

Commandline class shell injection vulnerabilities

Also known asGHSA-rhgr-952r-6p8q
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%1.89%3.78%5.67%0.3%4.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.maven.shared:maven-shared-utils

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache Maven maven-shared-utils prior to version 3.3.3, the Commandline class can emit double-quoted strings without proper escaping, allowing shell injection attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.maven.shared:maven-shared-utilsall versions3.3.3org.apache.maven.shared:maven-shared-utils:3.3.3

Affected Products

2 products · 3 configurations
Application
maven shared utilsapache
< 3.3.3
range
OS
debian linuxdebian
2 versions
10.011.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.maven.shared:maven-shared-utils, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.maven.shared:maven-shared-utils to 3.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29599 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat Satellite ships Candlepin component, which uses the Tomcatjss module from the RHEL AppStream repository. In turn, Tomcatjss relies on Maven, which itself depends on affected Apache Maven Shared Utils. Due to the fact that Satellite does not directly use Apache Maven Shared Utils, or expose it in its code, it…

ProductFixed inAdvisory
OCP-Tools-4.12-RHEL-8jenkins-2-plugins-0:4.12.1686649756-1.el8RHSA-2023:3610
OCP-Tools-4.12-RHEL-8jenkins-2-plugins-0:4.12.1698294000-1.el8RHSA-2023:6172
OCP-Tools-4.12-RHEL-8jenkins-2-plugins-0:4.12.1706515741-1.el8RHSA-2024:0778
OCP-Tools-4.13-RHEL-8jenkins-2-plugins-0:4.13.1686680473-1.el8RHSA-2023:3622
OCP-Tools-4.13-RHEL-8jenkins-2-plugins-0:4.13.1698292274-1.el8RHSA-2023:6179
OCP-Tools-4.13-RHEL-8jenkins-2-plugins-0:4.13.1706516346-1.el8RHSA-2024:0776
OCP-Tools-4.14-RHEL-8jenkins-2-plugins-0:4.14.1699356715-1.el8RHSA-2023:7288
OCP-Tools-4.14-RHEL-8jenkins-2-plugins-0:4.14.1706516441-1.el8RHSA-2024:0777

Frequently Asked Questions

In Apache Maven maven-shared-utils prior to version 3.3.3, the Commandline class can emit double-quoted strings without proper escaping, allowing shell injection attacks.
O3 Security · Impact-Aware SCA

Is CVE-2022-29599 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-29599: maven-shared-utils — Fixed in 3.3.3