NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-29546 — neko-htmlunit

HIGHFix: HtmlUnit/htmlunit-neko@9d2aecd

CVE-2022-29546 is a high-severity (CVSS 7.5) vulnerability in net.sourceforge.htmlunit:neko-htmlunit. A fix is available for net.sourceforge.htmlunit:neko-htmlunit — see the affected versions and patch details below.

OutOfMemory Exception by specifically crafted processing instruction in NekoHtml Parser

Also known asGHSA-6jmm-mp6w-4rrg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29546.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.75%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕net.sourceforge.htmlunit:neko-htmlunit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

NekoHtml Parser suffers from a denial of service vulnerability on versions 2.60.0 and below. A specifically crafted input regarding the parsing of processing instructions leads to heap memory consumption. Please update to version 2.61.0.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavennet.sourceforge.htmlunit:neko-htmlunitall versions2.61.0net.sourceforge.htmlunit:neko-htmlunit:2.61.0

Affected Products

1 product · 1 configurations
Application
htmlunithtmlunit
< 2.61.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for net.sourceforge.htmlunit:neko-htmlunit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update net.sourceforge.htmlunit:neko-htmlunit to 2.61.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29546 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact NekoHtml Parser suffers from a denial of service vulnerability on versions 2.60.0 and below. A specifically crafted input regarding the parsing of processing instructions leads to heap memory consumption. Please update to version 2.61.0. ### For more information If you have any questions or comments about this advisory: * Open an issue in [https://github.com/HtmlUnit/htmlunit-neko](https://github.com/HtmlUnit/htmlunit-neko) * Email us at [rbri at rbri.de]
O3 Security · Impact-Aware SCA

Is CVE-2022-29546 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-29546: neko-htmlunit DoS — Fixed in 2.61.0