NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-2932 — mobiledoc-kit

CRITICALFix: bustle/mobiledoc-kit@f3fdaa5

CVE-2022-2932 is a critical-severity (CVSS 9.8) Cross-site Scripting (XSS) vulnerability in mobiledoc-kit. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mobiledoc-kit — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Reflected in bustle/mobiledoc-kit

Also known asGHSA-hw2p-xqhq-3mjf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.42%0.4%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

11other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mobiledoc-kitnpm
3Kdownloads / week

Description

Cross-site Scripting (XSS) - Reflected in GitHub repository bustle/mobiledoc-kit prior to 0.14.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmobiledoc-kitall versions0.14.2npm install mobiledoc-kit@0.14.2

Affected Products

1 product · 1 configurations
Application
mobiledoc kitbdg
< 0.14.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mobiledoc-kit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mobiledoc-kit to 0.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2932 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Reflected in GitHub repository bustle/mobiledoc-kit prior to 0.14.2.
O3 Security · Impact-Aware SCA

Is CVE-2022-2932 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-2932: mobiledoc-kit XSS — Fixed in 0.14.2