NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-2930 — octoprint

MEDIUMFix: octoprint/octoprint@1453076

CVE-2022-2930 is a medium-severity (CVSS 5.3) CWE-620 vulnerability in octoprint. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for octoprint — see the affected versions and patch details below.

Unverified Password Change in octoprint/octoprint

Also known asGHSA-39gf-864w-pxw4PYSEC-2022-43142
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs28th percentile — riskier than 28% of all scored CVEsHighest risk
0.00%0.28%0.56%0.85%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍octoprint

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Versions of OctoPrint prior to 1.8.3 did not require the current user password in order to change that users password. As a result users could be locked out of their accounts or have their accounts stolen under certain circumstances.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIoctoprintall versions1.8.3pip install --upgrade 'octoprint==1.8.3'

Affected Products

1 product · 1 configurations
Application
octoprintoctoprint
< 1.8.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for octoprint, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update octoprint to 1.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2930 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Versions of OctoPrint prior to 1.8.3 did not require the current user password in order to change that users password. As a result users could be locked out of their accounts or have their accounts stolen under certain circumstances.
O3 Security · Impact-Aware SCA

Is CVE-2022-2930 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-2930: octoprint — Fixed in 1.8.3