NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-2927 — notrinos-erp

HIGHFix: notrinos/notrinoserp@e61e76b

CVE-2022-2927 is a high-severity (CVSS 7.3) CWE-521 vulnerability in notrinos/notrinos-erp. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for notrinos/notrinos-erp — see the affected versions and patch details below.

Weak Password Requirements in notrinos/notrinoserp

Also known asGHSA-qhm8-69qh-g76j
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.95%1.43%0.4%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘notrinos/notrinos-erp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In versions of notrinos/notrinoserp prior to 0.7 new account passwords were missing a password strength check.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnotrinos/notrinos-erpall versions0.7composer require notrinos/notrinos-erp:^0.7

Affected Products

1 product · 1 configurations
Application
notrinoserpnotrinos
< 0.7
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for notrinos/notrinos-erp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update notrinos/notrinos-erp to 0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2927 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In versions of notrinos/notrinoserp prior to 0.7 new account passwords were missing a password strength check.
O3 Security · Impact-Aware SCA

Is CVE-2022-2927 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-2927: notrinos-erp — Fixed in 0.7