CVE-2022-29253 is a low-severity (CVSS 2.7) Path Traversal vulnerability in org.xwiki.platform:xwiki-platform-oldcore. A fix is available for org.xwiki.platform:xwiki-platform-oldcore — see the affected versions and patch details below.
Path Traversal in XWiki Platform
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29253.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-oldcoreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
One can ask for any file located in the classloader using the template API and a path with ".." in it. For example
{{template name="../xwiki.hbm.xml"/}}
To our knownledge none of the available files of the classloader in XWiki Standard contain any strong confidential data, hence the low confidentiality value of this advisory.
Patches
The issue is patched in versions 14.0 and 13.10.3.
Workarounds
There's no easy workaround for this issue, administrators should upgrade their wiki.
References
- https://jira.xwiki.org/browse/XWIKI-19349
- https://github.com/xwiki/xwiki-platform/commit/4917c8f355717bb636d763844528b1fe0f95e8e2
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki
- Email us at security mailing list
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-oldcore | ≥ 8.3-rc-1&&< 13.10.3 | 13.10.3org.xwiki.platform:xwiki-platform-oldcore:13.10.3 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-oldcore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-oldcore to 13.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29253 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2022-29253 in your dependencies?
Find it across Maven, including transitive dependencies.