CVE-2022-29237 is a medium-severity (CVSS 5.4) Improper Authentication vulnerability in org.opencastproject:opencast-ingest-service-impl. A fix is available for org.opencastproject:opencast-ingest-service-impl — see the affected versions and patch details below.
Limited Authentication Bypass for Media Files in Opencast
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29237.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.opencastproject:opencast-ingest-service-impl☕org.opencastproject:opencast-ingest-service-implReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Prior to Opencast 10.14 and 11.7, users could pass along URLs for files belonging to organizations other than the user's own, which Opencast would then import into the current organization, bypassing organizational barriers.
Impact
The vulnerability allows attackers to bypass organizational barriers. Attackers must have full access to Opencast's ingest REST interface, and also know internal links to resources in another organization of the same Opencast cluster.
If you do not run a multi-tenant cluster, you are not affected by this issue.
Patches
This issue is fixed in Opencast 10.14 and 11.7.
References
For more information
If you have any questions or comments about this advisory:
- Open an issue in our issue tracker
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opencastproject:opencast-ingest-service-impl | all versions | 10.14org.opencastproject:opencast-ingest-service-impl:10.14 |
| ☕Maven | org.opencastproject:opencast-ingest-service-impl | ≥ 11.0&&< 11.7 | 11.7org.opencastproject:opencast-ingest-service-impl:11.7 |
Affected Products
opencastapereoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opencastproject:opencast-ingest-service-impl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opencastproject:opencast-ingest-service-impl to 10.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29237 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-29237 in your dependencies?
Find it across Maven, including transitive dependencies.