CVE-2022-29162 is a medium-severity (CVSS 5.9) Incorrect Default Permissions vulnerability in github.com/opencontainers/runc. A fix is available for github.com/opencontainers/runc — see the affected versions and patch details below.
Incorrect Default Permissions in runc
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29162.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/opencontainers/runcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A bug was found in runc where runc exec --cap executed processes with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during execve(2).
This bug did not affect the container security sandbox as the inheritable set never contained more capabilities than were included in the container's bounding set.
Patches
This bug has been fixed in runc 1.1.2. Users should update to this version as soon as possible.
This fix changes runc exec --cap behavior such that the additional capabilities granted to the process being executed (as specified via --cap arguments) do not include inheritable capabilities.
In addition, runc spec is changed to not set any inheritable capabilities in the created example OCI spec (config.json) file.
Credits
The opencontainers project would like to thank Andrew G. Morgan for responsibly disclosing this issue in accordance with the opencontainers org security policy.
For more information
If you have any questions or comments about this advisory:
- Open an issue
- Email us at [email protected] if you think you’ve found a security bug
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/opencontainers/runc | all versions | 1.1.2go get github.com/opencontainers/runc@v1.1.2 |
Affected Products
fedorafedoraprojectrunclinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/opencontainers/runc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/opencontainers/runc to 1.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29162 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue is rated as low severity as the vulnerability can only result in atypical linux environment,and it's complex exploitation only results in minimal impact on system confidentiality, integrity, and availability in typical environments.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2022-29162 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | container-tools:rhel8-8070020220929222448.39077419 | RHSA-2022:7457 |
| Red Hat Enterprise Linux 8 | container-tools:4.0-8070020220830101436.39077419 | RHSA-2022:7469 |
| Red Hat Enterprise Linux 9 | runc-4:1.1.4-1.el9 | RHSA-2022:8090 |
| Red Hat OpenShift Container Platform 4.11 | runc-3:1.1.2-1.rhaos4.11.el8 | RHSA-2022:5068 |
Frequently Asked Questions
Is CVE-2022-29162 in your dependencies?
Find it across Go, including transitive dependencies.