NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2022-29047 — workflow-cps-global-lib

HIGHFix: jenkinsci/workflow-cps-global-lib-plugin@97bf324

CVE-2022-29047 is a high-severity (CVSS 7.3) CWE-863 vulnerability in org.jenkins-ci.plugins.workflow:workflow-cps-global-lib. A fix is available for org.jenkins-ci.plugins.workflow:workflow-cps-global-lib — see the affected versions and patch details below.

Untrusted users can modify some Pipeline libraries in Jenkins Pipeline: Deprecated Groovy Libraries Plugin

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29047.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.56%1.13%1.69%0.1%1.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.plugins.workflow:workflow-cps-global-lib☕org.jenkins-ci.plugins.workflow:workflow-cps-global-lib

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multibranch Pipelines by default limit who can change the Pipeline definition from the Jenkinsfile. This is useful for SCMs like GitHub: Jenkins can build content from users without commit access, but who can submit pull requests, without granting them the ability to modify the Pipeline definition. In that case, Jenkins will just use the Pipeline definition in the pull request’s destination branch instead.

In Pipeline: Deprecated Groovy Libraries Plugin 564.ve62a_4eb_b_e039 and earlier the same protection does not apply to uses of the library step with a retriever argument pointing to a library in the current build’s repository and branch (e.g., library(…, retriever: legacySCM(scm))). This allows attackers able to submit pull requests (or equivalent), but not able to commit directly to the configured SCM, to effectively change the Pipeline behavior by changing the library behavior in their pull request, even if the Pipeline is configured to not trust them.

Pipeline: Deprecated Groovy Libraries Plugin 566.vd0a_a_3334a_555 and 2.21.3 aborts library retrieval if the library would be retrieved from the same repository and revision as the current build, and the revision being built is untrusted.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins.workflow:workflow-cps-global-liball versions2.21.3org.jenkins-ci.plugins.workflow:workflow-cps-global-lib:2.21.3
☕Mavenorg.jenkins-ci.plugins.workflow:workflow-cps-global-lib≥ 544.vff04fa68714d&&< 566.vd0a566.vd0aorg.jenkins-ci.plugins.workflow:workflow-cps-global-lib:566.vd0a

Affected Products

1 product · 2 configurations
Application
pipeline\jenkins
≥ 544.vff04fa68714d && < 566.vd0a_a_3334a_555
1 version
_shared_groovy_libraries

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins.workflow:workflow-cps-global-lib, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins.workflow:workflow-cps-global-lib to 2.21.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29047 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
OCP-Tools-4.12-RHEL-8jenkins-2-plugins-0:4.12.1675702407-1.el8RHSA-2023:1064
Red Hat OpenShift Container Platform 4.7jenkins-2-plugins-0:4.7.1652967082-1.el8RHSA-2022:4909
Red Hat OpenShift Container Platform 4.8jenkins-2-plugins-0:4.8.1672842762-1.el8RHSA-2023:0017
Red Hat OpenShift Container Platform 4.9jenkins-2-plugins-0:4.9.1651754460-1.el8RHSA-2022:2205

Frequently Asked Questions

Multibranch Pipelines by default limit who can change the Pipeline definition from the Jenkinsfile. This is useful for SCMs like GitHub: Jenkins can build content from users without commit access, but who can submit pull requests, without granting them the ability to modify the Pipeline definition. In that case, Jenkins will just use the Pipeline definition in the pull request’s destination branch instead. In Pipeline: Deprecated Groovy Libraries Plugin 564.ve62a_4eb_b_e039 and earlier the same protection does not apply to uses of the `library` step with a `retriever` argument pointing to a l
O3 Security · Impact-Aware SCA

Is CVE-2022-29047 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-29047: workflow-cps-global-lib — Fixed in 2.21.3