CVE-2022-28220 — james-server
HIGHCVE-2022-28220 is a high-severity (CVSS 7.5) CWE-77 vulnerability in org.apache.james:james-server. A fix is available for org.apache.james:james-server — see the affected versions and patch details below.
STARTTLS command injection in Apache JAMES
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.james:james-server☕org.apache.james:james-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache James prior to release 3.6.3 and 3.7.1 is vulnerable to a buffering attack relying on the use of the STARTTLS command. Fix of CVE-2021-38542, which solved similar problem fron Apache James 3.6.1, is subject to a parser differential and do not take into account concurrent requests.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.james:james-server | all versions | 3.6.3org.apache.james:james-server:3.6.3 |
| ☕Maven | org.apache.james:james-server | ≥ 3.7.0&&< 3.7.1 | 3.7.1org.apache.james:james-server:3.7.1 |
Affected Products
jamesapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.james:james-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.james:james-server to 3.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-28220 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2022-28220 in your dependencies?
Find it across Maven, including transitive dependencies.