CVE-2022-28111 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in com.github.pagehelper:pagehelper. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for com.github.pagehelper:pagehelper — see the affected versions and patch details below.
MyBatis PageHelper vulnerable to time-blind SQL injection via orderBy parameter
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.github.pagehelper:pagehelperReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
MyBatis PageHelper v1.x.x-v3.7.0 v4.0.0-v5.0.0,v5.1.0-v5.3.0 was discovered to contain a time-blind SQL injection vulnerability via the orderBy parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.github.pagehelper:pagehelper | ≥ 3.5.0&&< 5.3.1 | 5.3.1com.github.pagehelper:pagehelper:5.3.1 |
Affected Products
pagehelperpagehelper_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.github.pagehelper:pagehelper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.github.pagehelper:pagehelper to 5.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-28111 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2022-28111 in your dependencies?
Find it across Maven, including transitive dependencies.