CVE-2022-2733 is a critical-severity (CVSS 9.6) Cross-site Scripting (XSS) vulnerability. 1 public exploit reference exists, so weaponization risk is real. A fix is available — see the affected versions and patch details below.
Cross-site Scripting (XSS) - Reflected in openemr/openemr
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2022-2733 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).
Where this sits among everything scored
Of 397,508 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository openemr/openemr prior to 7.0.0.1.
Affected Products
openemropen-emrResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
VulnerabilityDetect
Identify every host running the affected component and compare the installed build against the fixed version below — for source-built or distro-packaged software the version string, not a lockfile, is the source of truth (`dpkg -l`, `rpm -q`, or the binary's own `--version`).
Fix
Upgrade the affected component to the fixed release for CVE-2022-2733, or apply your distribution's backported patch — distro builds are often patched at an older version number, so check your vendor's advisory rather than the upstream version alone.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
How to detect CVE-2022-2733
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2022-2733 -u https://target- Template
- Openemr < 7.0.0.1 - Cross-Site Scripting
- Severity
- medium
- Impact
- Successful exploitation of this vulnerability could allow an attacker to execute malicious scripts in the context of the victim's browser, potentially leading to session hijacking, defacement, or theft of sensitive information.
- Remediation
- Upgrade Openemr to version 7.0.0.1 or later to mitigate this vulnerability.
Template by ProjectDiscovery nuclei-templates (ctflearner), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2022-2733 in your dependencies?
Find it across , including transitive dependencies.