NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-27200 — folder-auth

MEDIUMFix: jenkinsci/folder-auth-plugin@085df58

CVE-2022-27200 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in io.jenkins.plugins:folder-auth. A fix is available for io.jenkins.plugins:folder-auth — see the affected versions and patch details below.

Stored Cross-site Scripting in folder-auth plugin

Also known asGHSA-5vjc-qx43-r747
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.38%0.75%1.13%0.2%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.jenkins.plugins:folder-auth

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Folder-based Authorization Strategy Plugin 1.3 and earlier does not escape the names of roles shown on the configuration form.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission.

Folder-based Authorization Strategy Plugin 1.4 escapes the names of roles shown on the configuration form.

See https://www.jenkins.io/security/advisory/2022-03-15/#SECURITY-2646

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.jenkins.plugins:folder-authall versions1.4io.jenkins.plugins:folder-auth:1.4

Affected Products

1 product · 1 configurations
Application
folder-based authorization strategyjenkins
≤ 1.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.jenkins.plugins:folder-auth, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.jenkins.plugins:folder-auth to 1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-27200 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Folder-based Authorization Strategy Plugin 1.3 and earlier does not escape the names of roles shown on the configuration form. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Overall/Administer permission. Folder-based Authorization Strategy Plugin 1.4 escapes the names of roles shown on the configuration form. See https://www.jenkins.io/security/advisory/2022-03-15/#SECURITY-2646
O3 Security · Impact-Aware SCA

Is CVE-2022-27200 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-27200: folder-auth XSS — Fixed in 1.4