NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2022-26884 — dolphinscheduler

MEDIUM

CVE-2022-26884 is a medium-severity (CVSS 6.5) Path Traversal vulnerability in org.apache.dolphinscheduler:dolphinscheduler. A fix is available for org.apache.dolphinscheduler:dolphinscheduler — see the affected versions and patch details below.

Apache DolphinScheduler exposes files without authentication

Also known asGHSA-vpgf-fgm8-gxr2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-26884.

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.99%1.43%1.88%2.32%1.6%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.dolphinscheduler:dolphinscheduler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.dolphinscheduler:dolphinschedulerall versions2.0.6org.apache.dolphinscheduler:dolphinscheduler:2.0.6

Affected Products

1 product · 1 configurations
Application
dolphinschedulerapache
< 2.0.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.dolphinscheduler:dolphinscheduler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.dolphinscheduler:dolphinscheduler to 2.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-26884 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
O3 Security · Impact-Aware SCA

Is CVE-2022-26884 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-26884: dolphinscheduler — Fixed in 2.0.6