CVE-2022-26788 — Microsoft.PowerShell.SDK
HIGHCVE-2022-26788 is a high-severity (CVSS 7.8) vulnerability in Microsoft.PowerShell.SDK. A fix is available for Microsoft.PowerShell.SDK — see the affected versions and patch details below.
PowerShell Elevation of Privilege Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Microsoft.PowerShell.SDK.NETMicrosoft.PowerShell.SDK.NETMicrosoft.PowerShell.SDKReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
PowerShell Elevation of Privilege Vulnerability
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Microsoft.PowerShell.SDK | ≥ 7.0.0-preview.1&&< 7.0.10 | 7.0.10dotnet add package Microsoft.PowerShell.SDK --version 7.0.10 |
| .NETNuGet | Microsoft.PowerShell.SDK | ≥ 7.1.0-preview.1&&< 7.1.7 | 7.1.7dotnet add package Microsoft.PowerShell.SDK --version 7.1.7 |
| .NETNuGet | Microsoft.PowerShell.SDK | ≥ 7.2.0-preview.1&&< 7.2.3 | 7.2.3dotnet add package Microsoft.PowerShell.SDK --version 7.2.3 |
Affected Products
powershellmicrosoftwindows 8.1microsoftwindows 10microsoftwindows 11microsoftwindows rt 8.1microsoftwindows server 2008microsoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.PowerShell.SDK, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Microsoft.PowerShell.SDK to 7.0.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-26788 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-26788 in your dependencies?
Find it across NuGet, including transitive dependencies.