NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-25979 — jsuites

MEDIUMFix: jsuites/jsuites@b31770d

CVE-2022-25979 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in jsuites. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for jsuites — see the affected versions and patch details below.

jSuites subect to Cross-site Scripting

Also known asGHSA-r4hg-4cpq-q57c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-25979.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.37%0.74%1.12%0.3%0.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

60other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jsuitesnpm
140Kdownloads / week

Description

Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmjsuitesall versions5.0.1npm install jsuites@5.0.1

Affected Products

1 product · 1 configurations
Application
jsuitesjsuites
< 5.0.1
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsuites, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jsuites to 5.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25979 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Versions of the package jsuites before 5.0.1 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization in the Editor() function.
O3 Security · Impact-Aware SCA

Is CVE-2022-25979 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-25979: jsuites XSS — Fixed in 5.0.1