NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-25916 — mt7688-wiscan

HIGHFix: simenkid/mt7688-wiscan@ff6d656

CVE-2022-25916 is a high-severity (CVSS 7.4) OS Command Injection vulnerability in mt7688-wiscan. A fix is available for mt7688-wiscan — see the affected versions and patch details below.

mt7688-wiscan is vulnerable to Command Injection due to improper input sanitization

Also known asGHSA-5h8c-8ccp-8gmh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-25916.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.53%1.07%1.60%0.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mt7688-wiscannpm
29downloads / week

Description

Versions of the package mt7688-wiscan before 0.8.3 are vulnerable to Command Injection due to improper input sanitization in the 'wiscan.scan' function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmt7688-wiscanall versions0.8.3npm install mt7688-wiscan@0.8.3

Affected Products

1 product · 1 configurations
Application
mt7688-wiscanmt7688-wiscan_project
< 0.8.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mt7688-wiscan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mt7688-wiscan to 0.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25916 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Versions of the package mt7688-wiscan before 0.8.3 are vulnerable to Command Injection due to improper input sanitization in the 'wiscan.scan' function.
O3 Security · Impact-Aware SCA

Is CVE-2022-25916 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-25916: mt7688-wiscan — Fixed in 0.8.3