NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-25875 — svelte

MEDIUMFix: sveltejs/svelte@f8605d6

CVE-2022-25875 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in svelte. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for svelte — see the affected versions and patch details below.

Cross-site Scripting (XSS)

Also known asGHSA-wv8q-r932-8hc7SNYK-JS-SVELTE-2931080
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.23%0.80%1.37%1.94%0.7%1.4%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
sveltenpm
9.0Mdownloads / week

Description

The package svelte before 3.49.0 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsvelteall versions3.49.0npm install svelte@3.49.0

Affected Products

1 product · 1 configurations
Application
sveltesvelte
< 3.49.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for svelte, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update svelte to 3.49.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25875 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The package svelte before 3.49.0 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.
O3 Security · Impact-Aware SCA

Is CVE-2022-25875 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-25875: svelte XSS — Fixed in 3.49.0