NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-25873 — vuetify

MEDIUMFix: vuetifyjs/vuetify@ade1434

CVE-2022-25873 is a medium-severity (CVSS 4.6) Cross-site Scripting (XSS) vulnerability in org.webjars.npm:vuetify. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.webjars.npm:vuetify — see the affected versions and patch details below.

Cross-site Scripting (XSS)

Also known asGHSA-q4q5-c5cv-2p68
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.05%0.49%0.93%1.37%0.6%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
vuetifynpm
1.3Mdownloads / week

Description

The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars.npm:vuetify≥ 2.0.0-beta.4&&< 2.6.102.6.10org.webjars.npm:vuetify:2.6.10
📦npmvuetify≥ 2.0.0-beta.4&&< 2.6.102.6.10npm install vuetify@2.6.10

Affected Products

1 product · 7 configurations
Application
vuetifyvuetifyjs
≥ 2.0.1 && < 2.6.10
1 version
2.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:vuetify, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars.npm:vuetify to 2.6.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25873 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
O3 Security · Impact-Aware SCA

Is CVE-2022-25873 in your dependencies?

Find it across Maven, npm, including transitive dependencies.

CVE-2022-25873: vuetify XSS — Fixed in 2.6.10