CVE-2022-25648 is a high-severity (CVSS 8.1) CWE-88 vulnerability in git. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for git — see the affected versions and patch details below.
Command Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
gitReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The package prior to v1.11.0 is vulnerable to Command Injection via git argument injection. When calling the fetch(remote = 'origin', opts = {}) function, the remote parameter is passed to the git fetch subcommand in a way such that additional flags can be set. The additional flags can be used to perform a command injection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | git | all versions | 1.11.0bundle update git --conservative |
Affected Products
debian linuxdebianextra packages for enterprise linuxfedoraprojectfedorafedoraprojectgitgitResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for git, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update git to 1.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25648 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Satellite 10 is marked as affected, as it is shipping the vulnerable code. However, the dependency is not used within the product as such, so the impact is considered as moderate. Other Red Hat Satellite versions are not delivering this dependency, so they are not vulnerable or affected at all.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.12 for RHEL 8 | tfm-rubygem-git-0:1.11.0-1.el8sat | RHSA-2022:8506 |
Frequently Asked Questions
Is CVE-2022-25648 in your dependencies?
Find it across RubyGems, including transitive dependencies.