CVE-2022-25508 — freetakserver
HIGHCVE-2022-25508 is a high-severity (CVSS 7.5) Missing Authentication vulnerability in freetakserver. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for freetakserver — see the affected versions and patch details below.
Improper Authentication in FreeTAKServer
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
freetakserverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
FreeTAKServer is an open source, lightweight Server for connect TAK clients. An access control issue in the component /ManageRoute/postRoute of FreeTAKServer version 1.9.8 allows unauthenticated attackers to cause a Denial of Service (DoS) via an unusually large amount of created routes, or create unsafe or false routes for legitimate users. There is currently no known workaround. This issue was fixed in version 1.9.8.5.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | freetakserver | all versions | 1.9.8.5pip install --upgrade 'freetakserver==1.9.8.5' |
Affected Products
freetakserver-uifreetakserver-ui_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for freetakserver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update freetakserver to 1.9.8.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25508 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-25508 in your dependencies?
Find it across PyPI, including transitive dependencies.