NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-25304 — asyncua

HIGHFix: FreeOpcUa/opcua-asyncio@01c7acf

CVE-2022-25304 is a high-severity (CVSS 7.5) CWE-770 vulnerability in asyncua. A fix is available for asyncua — see the affected versions and patch details below.

Uncontrolled Resource Consumption in asyncua and opcua

Also known asGHSA-mfpj-3qhm-976mPYSEC-2026-2385PYSEC-2026-888
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.03%0.65%1.26%1.87%0.5%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍asyncua🐍opcua

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

All versions of package opcua; all versions of package asyncua are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIasyncuaall versions0.9.96pip install --upgrade 'asyncua==0.9.96'
🐍PyPIopcuaall versionsNo fix

Affected Products

2 products · 2 configurations
Application
asyncuaasyncua_project
all
Application
opcuaopcua_project
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for asyncua, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update asyncua to 0.9.96 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25304 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

All versions of package opcua; all versions of package asyncua are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.
O3 Security · Impact-Aware SCA

Is CVE-2022-25304 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-25304: asyncua DoS — Fixed in 0.9.96