CVE-2022-24898 is a medium-severity (CVSS 4.9) XML External Entity (XXE) vulnerability in org.xwiki.commons:xwiki-commons-xml. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.xwiki.commons:xwiki-commons-xml — see the affected versions and patch details below.
Arbitrary file access through XML parsing in org.xwiki.commons:xwiki-commons-xml
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.commons:xwiki-commons-xml☕org.xwiki.commons:xwiki-commons-xml☕org.xwiki.commons:xwiki-commons-xmlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
It's possible in a script to access any file accessing to the user running XWiki application server with XML External Entity Injection through the XML script service.
For example:
{{velocity}}
#set($xml=$services.get('xml'))
#set($xxe_payload = "<?xml version='1.0' encoding='UTF-8'?><!DOCTYPE root[<!ENTITY xxe SYSTEM 'file:///etc/passwd' >]><root><foo>&xxe;</foo></root>")
#set($doc=$xml.parse($xxe_payload))
$xml.serialize($doc)
{{/velocity}}
Patches
The problem has been patched on versions 12.10.10, 13.4.4 and 13.8RC1.
Workarounds
There's no easy workaround for fixing this vulnerability other than upgrading and being careful when giving Script rights.
References
https://jira.xwiki.org/browse/XWIKI-18946
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki
- Email us at XWiki Security mailing-list
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.commons:xwiki-commons-xml | ≥ 2.7&&< 12.10.10 | 12.10.10org.xwiki.commons:xwiki-commons-xml:12.10.10 |
| ☕Maven | org.xwiki.commons:xwiki-commons-xml | ≥ 13.0.0&&< 13.4.4 | 13.4.4org.xwiki.commons:xwiki-commons-xml:13.4.4 |
| ☕Maven | org.xwiki.commons:xwiki-commons-xml | ≥ 13.5-rc-1&&< 13.8-rc-1 | 13.8-rc-1org.xwiki.commons:xwiki-commons-xml:13.8-rc-1 |
Affected Products
commonsxwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.commons:xwiki-commons-xml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.commons:xwiki-commons-xml to 12.10.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24898 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-24898 in your dependencies?
Find it across Maven, including transitive dependencies.