NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
MEDIUM severity

CVE-2022-24512 — Microsoft.NETCore.App.Run…

MEDIUM

CVE-2022-24512 is a medium-severity (CVSS 6.3) Code Injection vulnerability in Microsoft.NETCore.App.Runtime.linux-arm. A fix is available for Microsoft.NETCore.App.Runtime.linux-arm — see the affected versions and patch details below.

.NET Remote Code Execution Vulnerability

Also known asBIT-dotnet-2022-24512BIT-dotnet-sdk-2022-24512BIT-powershell-2022-24512GHSA-c6w8-7mp3-34j9
Published
Updated
Affected
147 pkgs
Patched
147 / 147
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24512.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.70%1.41%2.11%0.2%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

147 pkgs affected
.NETMicrosoft.NETCore.App.Runtime.linux-arm.NETMicrosoft.NETCore.App.Runtime.linux-arm64.NETMicrosoft.NETCore.App.Runtime.linux-musl-arm64.NETMicrosoft.NETCore.App.Runtime.linux-musl-x64.NETMicrosoft.NETCore.App.Runtime.linux-x64.NETMicrosoft.NETCore.App.Runtime.osx-x64.NETMicrosoft.NETCore.App.Runtime.win-arm.NETMicrosoft.NETCore.App.Runtime.win-arm64+139 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0, and .NET Core 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A Remote Code Execution vulnerability exists in .NET 6.0, .NET 5.0, and .NET Core 3.1 where a stack buffer overrun occurs in .NET Double Parse routine.

Patches

  • Any .NET 6.0 application running on .NET 6.0.2 or lower
  • Any .NET 5.0 application running on .NET 5.0.14 or lower
  • Any .NET Core 3.1 application running on .NET Core 3.1.22 or lower

To fix the issue, please install the latest version of .NET 6.0, .NET 5.0, or .NET Core 3.1. If you have installed one or more .NET Core SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET Core SDKs.

  • If you're using .NET 6.0, you should download and install Runtime 6.0.3 or SDK 6.0.103 (for Visual Studio 2019 v17.0) or SDK 6.0.201 (for Visual Studio 2019 V17.1) from https://dotnet.microsoft.com/download/dotnet-core/5.0.
  • If you're using .NET 5.0, you should download and install Runtime 5.0.15 or SDK 5.0.406 (for Visual Studio 2019 v16.11) or SDK 5.0.212 (for Visual Studio 2019 V16.9) from https://dotnet.microsoft.com/download/dotnet-core/5.0.
  • If you're using .NET Core 3.1, you should download and install Runtime 3.1.23 or SDK 3.1.417 (for Visual Studio 2019 v16.7) from https://dotnet.microsoft.com/download/dotnet-core/3.1. .NET 6.0, .NET 5.0, and .NET Core 3.1 updates are also available from Microsoft Update. To access this either type "Check for updates" in your Windows search, or open Settings, choose Update & Security and then click Check for Updates.

Other Details

Affected Packages

147 total 147 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-arm≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-arm --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-arm64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-arm64 --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-musl-arm64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-musl-arm64 --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-musl-x64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-musl-x64 --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.linux-x64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.linux-x64 --version 3.1.23
.NETNuGetMicrosoft.NETCore.App.Runtime.osx-x64≥ 3.0.0&&< 3.1.233.1.23dotnet add package Microsoft.NETCore.App.Runtime.osx-x64 --version 3.1.23

Affected Products

6 products · 16 configurations
OS
fedorafedoraproject
3 versions
343536
Application
.netmicrosoft
2 versions
5.06.0.0
Application
.net coremicrosoft
1 version
3.1
Application
powershellmicrosoft
≥ 7.2 && < 7.2.2
range
Application
visual studio 2019microsoft
≥ 16.11.0 && ≤ 16.10.4
range
Application
visual studio 2022microsoft
≥ 17.0 && < 17.0.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.NETCore.App.Runtime.linux-arm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.NETCore.App.Runtime.linux-arm to 3.1.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24512 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
.NET Core on Red Hat Enterprise Linuxrh-dotnet31-dotnet-0:3.1.417-1.el7_9RHSA-2022:0829
.NET Core on Red Hat Enterprise Linuxrh-dotnet50-dotnet-0:5.0.212-1.el7_9RHSA-2022:0828
.NET Core on Red Hat Enterprise Linuxrh-dotnet60-dotnet-0:6.0.103-3.el7_9RHSA-2022:0832
Red Hat Enterprise Linux 8dotnet6.0-0:6.0.103-4.el8_5RHSA-2022:0826
Red Hat Enterprise Linux 8dotnet3.1-0:3.1.417-1.el8_5RHSA-2022:0827
Red Hat Enterprise Linux 8dotnet5.0-0:5.0.212-1.el8_5RHSA-2022:0830

Frequently Asked Questions

Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0, and .NET Core 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A Remote Code Execution vulnerability exists in .NET 6.0, .NET 5.0, and .NET Core 3.1 where a stack buffer overrun occurs in .NET Double Parse routine. ### Patches * Any .NET 6.0 application running on .NET 6.0.2 or lower * Any .NET 5.0 application running on .NET 5.0.14 or lower * Any .NET Core 3.1 application running on .NET Core 3.1.22 or
O3 Security · Impact-Aware SCA

Is CVE-2022-24512 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2022-24512: Microsoft.NETCore.App — Fixed in 3.1.23