NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-2422 — feathers-sequelize

CRITICALFix: feathersjs-ecosystem/feathers-sequelize@0f2d85f

CVE-2022-2422 is a critical-severity (CVSS 10) SQL Injection vulnerability in feathers-sequelize. A fix is available for feathers-sequelize — see the affected versions and patch details below.

Feathers - SQL injection via attribute aliases

Also known asGHSA-qpv8-4pjq-qqh7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.95%1.43%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

40other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
feathers-sequelizenpm
19Kdownloads / week

Description

Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in case the feathers-sequelize package is used.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmfeathers-sequelize≥ 6.0.0&&< 6.3.46.3.4npm install feathers-sequelize@6.3.4

Affected Products

1 product · 1 configurations
Application
feathers-sequelizefeathersjs
≥ 6.0.0 && < 6.3.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for feathers-sequelize, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update feathers-sequelize to 6.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2422 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in case the feathers-sequelize package is used.
O3 Security · Impact-Aware SCA

Is CVE-2022-2422 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-2422: feathers SQL Injection — Fixed in 6.3.4