NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2022-24093 — community-edition

CRITICAL

CVE-2022-24093 is a critical-severity (CVSS 9.1) Improper Input Validation vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Adobe Commerce post-auth improper input validation leads to remote code execution

Also known asGHSA-5xmp-7wg5-x68q
Published
Updated
Affected
5 pkgs
Patched
2 / 5
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24093.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.62%1.08%1.55%2.01%1.1%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/project-community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

Affected Packages

5 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.4.3-p1&&< 2.4.3-p22.4.3-p2composer require magento/community-edition:^2.4.3-p2
🐘Packagistmagento/community-edition≥ 2.3.7-p1&&< 2.3.7-p32.3.7-p3composer require magento/community-edition:^2.3.7-p3
🐘Packagistmagento/project-community-editionall versionsNo fix

Affected Products

2 products · 12 configurations
Application
commerceadobe
≥ 2.4.0 && < 2.4.3
2 versions
2.3.72.4.3
Application
magento open sourceadobe
≥ 2.4.0 && < 2.4.3
2 versions
2.3.72.4.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2022-24093; check the affected-versions list above or the advisory for the patched release of magento/community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.
O3 Security · Impact-Aware SCA

Is CVE-2022-24093 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-24093: community RCE — Fixed in 2.4.3-p2