NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2022-23837 — sidekiq

HIGHFix: mperham/sidekiq@7785ac1

CVE-2022-23837 is a high-severity (CVSS 7.5) CWE-770 vulnerability in sidekiq. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for sidekiq — see the affected versions and patch details below.

Denial of service in sidekiq

Also known asGHSA-jrfj-98qg-qjgv
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.20%4.41%6.61%0.8%5.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎sidekiq💎sidekiq

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemssidekiq≥ 6.0.0&&< 6.4.06.4.0bundle update sidekiq --conservative
💎RubyGemssidekiqall versions5.2.10bundle update sidekiq --conservative

Affected Products

2 products · 3 configurations
Application
sidekiqcontribsys
≥ 6.0.0 && < 6.4.0
range
OS
debian linuxdebian
1 version
9.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sidekiq, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sidekiq to 6.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23837 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Satellite 6.11 for RHEL 7tfm-rubygem-sidekiq-0:5.2.10-1.el7satRHSA-2022:5498

Frequently Asked Questions

In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.
O3 Security · Impact-Aware SCA

Is CVE-2022-23837 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2022-23837: sidekiq — Fixed in 6.4.0