CVE-2022-23799 is a critical-severity (CVSS 9.8) vulnerability in joomla/input. A fix is available for joomla/input — see the affected versions and patch details below.
Variable Tampering within joomla/input class
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
joomla/inputReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Joomla! 4.0.0 through 4.1.0. Under specific circumstances, JInput pollutes method-specific input bags with $_REQUEST data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | joomla/input | ≥ 2.0.0&&< 2.0.2 | 2.0.2composer require joomla/input:^2.0.2 |
Affected Products
joomla\!joomlaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for joomla/input, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update joomla/input to 2.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23799 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-23799 in your dependencies?
Find it across Packagist, including transitive dependencies.