CVE-2022-23536 is a medium-severity (CVSS 6.5) CWE-73 vulnerability in github.com/cortexproject/cortex. A fix is available for github.com/cortexproject/cortex — see the affected versions and patch details below.
Alertmanager can expose local files content via specially crafted config
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-23536.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/cortexproject/cortex🐹github.com/cortexproject/cortexReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A local file inclusion vulnerability exists in Cortex versions v1.13.0, v1.13.1 and v1.14.0, where a malicious actor could remotely read local files as a result of parsing maliciously crafted Alertmanager configurations when submitted to the Alertmanager Set Configuration API. Only users of the Cortex Alertmanager service using -experimental.alertmanager.enable-api or enable_api: true are affected.
Specific Go Packages Affected
github.com/cortexproject/cortex/pkg/alertmanager
Patches
Affected Cortex users are advised to upgrade to versions 1.13.2 or 1.14.1.
Workarounds
Patching is ultimately advised. Using out-of-bound validation, Cortex administrators may reject Alertmanager configurations containing the api_key_file setting in the opsgenie_configs section and opsgenie_api_key_file in the global section before sending to the Set Alertmanager Configuration API as a workaround.
References
For more information
If you have any questions or comments about this advisory:
- Open an issue in cortex
- Email us at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/cortexproject/cortex | ≥ 1.14.0&&< 1.14.1 | 1.14.1go get github.com/cortexproject/cortex@v1.14.1 |
| 🐹Go | github.com/cortexproject/cortex | ≥ 1.13.0&&< 1.13.2 | 1.13.2go get github.com/cortexproject/cortex@v1.13.2 |
Affected Products
cortexlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cortexproject/cortex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/cortexproject/cortex to 1.14.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23536 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-23536 in your dependencies?
Find it across Go, including transitive dependencies.