CVE-2022-23518 — rails-html-sanitizer
MEDIUMCVE-2022-23518 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in rails-html-sanitizer. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for rails-html-sanitizer — see the affected versions and patch details below.
Improper neutralization of data URIs allows XSS in rails-html-sanitizer
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rails-html-sanitizerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Summary
rails-html-sanitizer >= 1.0.3, < 1.4.4 is vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0.
Mitigation
Upgrade to rails-html-sanitizer >= 1.4.4.
Severity
The maintainers have evaluated this as Medium Severity 6.1.
References
- CWE - CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') (4.9)
- SVG MIME Type (image/svg+xml) is misleading to developers · Issue #266 · w3c/svgwg
- https://github.com/rails/rails-html-sanitizer/issues/135
- https://hackerone.com/reports/1694173
Credit
This vulnerability was independently reported by Maciej Piechota (@haqpl) and Mrinmoy Das (@goromlagche).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | rails-html-sanitizer | ≥ 1.0.3&&< 1.4.4 | 1.4.4bundle update rails-html-sanitizer --conservative |
Affected Products
debian linuxdebianloofahloofah_projectrails html sanitizersrubyonrailsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rails-html-sanitizer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rails-html-sanitizer to 1.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23518 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.13 for RHEL 8 | tfm-rubygem-rails-html-sanitizer-0:1.4.4-1.el8sat | RHSA-2023:2097 |
Frequently Asked Questions
Is CVE-2022-23518 in your dependencies?
Find it across RubyGems, including transitive dependencies.